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1. INTRODUCTION  

1.1. BOT’N ROLL ONE A+  

1.1.1. BOT’N ROLL ONE A+ - TO WHOM IS IT FOR?  

The Bot’n Roll ONE A+ Arduino compatible is an Open Source didactic product, which is intended for all 

those who wish to start with mobile robots despite not having much knowledge about electronics or 

computers. The assembly of this robot allows the first steps with some of the most common electronic 

components. The brief introduction to the basic components and explanation of some concepts along the 

assembly instructions allow a very enriching introductory approach that complements the electronic 

components assembling. 

Those who wish to get started in robotics find in Bot'n Roll ONE A+ the ideal tool to assemble a robot while 

not having the basic knowledge on robotics. 

Teachers will find the Bot'n Roll ONE A+ a working tool able to assist them in imparting knowledge to their 

students. From electronic to programming, this robot allows the study of a wide range of concepts in a 

very practical perspective. 

The most experienced will find this robotic kit an interesting challenge. The Bot'n Roll ONE A+ has two 

microcontrollers, one ATmega328 running at 16MHz, programmable in C language with Arduino IDE (like  

an Arduino UNO) and one PIC18F45K22 running at 80MHz programmable in C with MPLABX Microchip 

(supplied with firmware developed by botnroll.com). A library for the Arduino IDE specifically developed 

by botnroll.com allows interaction between the two microcontrollers. This kit comes with an alphanumeric 

LCD display with 2 two lines and 16 characters per line. 

This robot can be coupled with a wide range of Arduino compatible shields such as wireless 

communications, GPS, GPRS, and many other sensors and actuators to perform various tasks, which makes 

it suitable to participate in the major national and international robotic competitions. These competitions 

are always very inspiring for young people allowing them to see different solutions created by other teams, 

a source of motivation willing them to learn more. 

For more information, you can register on www.botnroll.com to keep you abreast of news. 

 

http://www.botnroll.com/
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1.1.2. BOT’N ROLL ONE A+ MAIN CHARACTERISTICS  

 

Microcontrollers: 1 ATmega328 + 1 PIC18F45K22 

Supply Voltage: 7V to 15V DC 

Digital I/O's: 14 (6 of which allow PWM) 

Analog Inputs: 6 (ATmega328) + 8 (PIC18F45K22) 

Dedicated Outputs for servo control: 2 (PIC18F45K22) 

Encoders Inputs: 2 (PIC18F45K22) 

I2C Connectors: 4 (ATmega328) 

LCD Display: 2x16 Alphanumeric with contrast and light control (PIC18F45K22) 

Push Buttons: 3 (PIC18F45K22) 

Obstacle Sensors: 2 (PIC18F45K22) 

Buzzer: 1 (ATmega328) 

Debugging LED´s: 1 

Motors: 2 (PIC18F45K22) 

• Nominal Voltage: 12V DC 

• Nominal Current: 0.58A 

• Rotation without load: 285rpm 

• Nominal Binary: 1.16Kg.cm 

• Maximum Instantaneous Binary: 1.74Kg.cm 

Dimensions: 205mm x 192mm x 85mm 

Weight: 800g (base kit without battery) 

Battery: Ni-MH AA 12V 800mAh  

Other characteristics: 

• Reset Button; 

• Circuit for measuring the battery voltage; 

• Allows to include a voltage regulator dedicated to servo feeding; 

• Microcontrollers communicate through SPI bus; 

• Protection against short-circuit with a 4A slow fuse. 
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1.1.3. BOT’N ROLL ONE A+ GENERAL OVERVIEW  

 

 

  

Obstacles Detection by Infrared 

Battery voltage 
measurement circuit 

Buzzer  

Slow Fuse to protect 
against short-circuits 

USB port to 
program the 
ATmega328 

Two 12V DC motors 
and two driving 

wheels 

Push Buttons 

14 Digital I/O’s 

I2C communication 
bus 

ATmega328 
Microprocessor 

Double H Bridge to 
drive the motors 

Caster Wheel and robot tilt adjustment 
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adjustment 

ON/OFF switch 
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PIC18F45K22 
Microprocessor  

Reset Button 

Debugging LED 
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Voltage Regulators 
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Interruptor ON/OFF 

Fig. 1: Bot'n Roll One A+ general overview 
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1.2. ROBOTICS  

1.2.1. HISTORICAL INTRODUCTION  

The word "robot" was first used in a theatre play "RUR" (Rossum's Universal 

Robots) written in 1920 by Karel Capek, a Czech playwright. In this piece, a 

character built several artificial men and used them to replace men work. It was 

the first time someone used this word to designate "artificial man". In its original 

language, (Czech) "Robota" means, "forced labour". Perhaps due to this 

secondary meaning, the robots are more associated with the industry. Even 

before this piece, the robots were called "Automan" by the Greeks, whose 

meaning is "to move automatically." 

 

 

 

 

1.2.2. THE THREE LAWS OF ROBOTICS  

Created by the writer Isaac Asimov in his fiction book I, Robot these laws 

dictate the expected behaviour of robots: 

1st law: a robot may not injure a human being, or through inaction allow 

a human being to come to harm. 

2nd law: a robot must obey the orders given it by human beings, except 

where such orders would conflict with the first law. 

3rd law: a robot must protect its own existence as long as such protection 

does not conflict with the first or second law. 

According to Asimov, the main objective of these laws was to make 

possible the existence of intelligent robots (the laws presume enough 

intelligence to distinguish between good and evil) in such way they would 

not rebel against the human domain. Later on, Asimov introduced one 

more law: 

Law Zero: A robot may not harm humanity, or, by inaction, allow 

humanity to come to harm. 

However, law zero, has the serious problem of transferring the power to the robot (possibility) to assess, 

in face of specific situations, if the interests of humanity overlaps the individual interest. Such possibility 

opens a dangerous loophole for machines dictatorship, which would elect by themselves the highest good, 

being even able to harm a human being should they understand that it is the best for humankind. 

These are not exactly laws in the real sense of the word, but just guidelines that all robotics enthusiasts 

and researchers implement when creating and developing robots. 

  

Fig. 2: Rossum's Universal Robots 

Fig. 3: Book “I Robot” by Isaac Asimov 

http://pt.wikipedia.org/wiki/Isaac_Asimov
http://pt.wikipedia.org/wiki/I,_Robot
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1.2.3. MAIN EVENTS AND SOCIETIES RELATED WITH ROBOTICS  

RoboCup® - http://www.robocup.org/ 

The RoboCup is a Robot world wide initiative for research and education, whose main objective is to 

promote artificial intelligence and robotics in general. Having a football game as the main challenge, new 

technologies are developed in all areas of robotics, so that a team of robots can win the human world 

champions in the year 2050. Every year this event takes place in a different country. 

S.P.R. - http://www.spr.ua.pt/site/ 

The Sociedade Portuguesa de Robótica (Portuguese Robotics Society also known as SPR) is a non-profitable 

association whose main objective is to promote and stimulate education, research and technological 

development, as well as industrial and servicing robotics applications. 

F.N.R. - http://www.spr.ua.pt/fnr/ 

The Festival Nacional de Robótica (Portuguese Open) was first held in 2001 in Guimarães, and has as main 

objective to promote science and technology in junior and secondary schools, in the university level, as 

well as in the general public, through simple and entertaining robot competitions. The Portuguese Open, 

is held annually in a different city and it includes a symposium where national and international 

researchers from the robotics field gather together to present the most recent activities of their research 

work. This event is an initiative from the Portuguese Robotics Society and it has had an incredible growth 

since its beginning, both in participants and in general public. 

RoboParty® – http://www.roboparty.org/ 

The RoboParty® is an educational event that gathers teams of 4 people, during 3 days and 2 nights 
(participants bring their sleeping bag) to teach how to build autonomous mobile robots in a simple and 
entertaining way, supported by qualified tutors. Initially, a short course is given to teach the first steps in 
electronics, robot programming and mechanical construction. Afterwards, a robotic kit developed by the 
company SAR - Soluções de Automação e Robótica and by University of Minho is supplied to be assembled 
by the participants (mechanics, electronics and programming), belonging to the team at the end of the 
event. The tutors follow closely the team's work at all stages, in order to assure that every robot works 
properly in the end. 

In parallel, there are several leisure activities such as sports, music, Internet, games, parties, etc. Each 
participant brings his sleeping bag and stays overnight during the whole event.  

The RoboParty® is identical to a LAN Party and it runs non-stop but with an educational and pedagogical 

purposes. Rules of important national and international robotic competitions are shown and explained so 

that youngsters can participate later on with the robot they build at RoboParty. 

botnroll.com – http://www.botnroll.com/ 

botnroll.com develops educational products in the robotics field. The products are excellent educational 

helpers for all those willing to start learning about robotics. Basic and secondary teachers can find in these 

products the ideal tool to teach mechanics, electronics and programming in their lectures. For the most 

experienced, there are also high technological mobile robotic solutions.  

  

http://www.robocup.org/
http://www.spr.ua.pt/site/
http://www.spr.ua.pt/fnr/
http://www.roboparty.org/
http://www.botnroll.com/
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1.3. ELECTRONICS – DEFINITIONS  

The electronics is the branch of science that studies the 

use of circuits consisting of electrical and electronic 

components, with the main aim to transform, transmit 

process and store energy.  

The electronics is the branch of physics that studies the 

issue and the effect of electrons and their use in 

electronic devices. 

Electronics studies essentially the electronic flow of 

charges through the semiconductor (non-metallic 

conductors).  

Electronics allows manipulating energy through flow, storage, distribution or conversion. It also allows 

acquiring, processing, converting, filtering and storing information, through electrical signals. 

Electronic Engineering consists on the application of the basic principles of electronic in technologies in 

order to solve practical problems. 

Fig. 4: Electronic Printed Circuit Board 
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2. BOT’N ROLL ONE A+ COMPONENTS  

When you first open your Bot'n Roll ONE A+ kit please verify that it contains the following components: 

 

 

 

 

Acrylic base 

 

 

 

 

 

 

Printed circuit Board 

 

 

 

 

 

 

3 component bags: 

• Major components 

• Small components 

• Line Sensor 
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1 - Box with mechanic components containing: 

• Two driving wheels  

• Battery accessories for placing and connection 

• Motor supports  

• Caster wheel  

• One Phillips screwdriver 

• One cross screwdriver 

 

2 - Small box containing: 

• Two DC motors  

• Two connector cables 

• Battery 

 

3 - USB Cable to connect the robot to the computer 

4 - Solder 

5 - Battery charger 

IMPORTANT NOTE: Should any component be missing, immediately contact the kit supplier for its 

replacement. 

1 

2 

4 

5 

3 

Fig. 5: Bot'n Roll ONE A+ Components 
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3. BATTERY 

Put the battery to charge utilizing the charger included with your kit before you begin the robot assembly. 

This way the battery will be ready to use when you finish building your robot! 

The provided battery is a Ni-MH (nickel metal hydride), 12V rated voltage and 800mAh rated current. 

3.1. CHARGING THE BATTERY  

Maximum Voltage: The battery is fully charged when its voltage stands between 14,5V and 15V. 

Minimum Voltage: The battery is considered discharged when its voltage its lower than 10V. 

Charging Current: The provided charger allows you to define the battery charging current. It's 

recommended a current equal or less than one-tenth of the rated current, for a battery of 800mAh the 

charging current must be: 800 / 10 = 80mA. 

Charging Time: The charging time is determined by the battery capacity multiplied by a factor of 1.4 and 

divided by the charging current: 800 x 1.4 / 80 = 14 hours. The battery must be disconnected from the 

charger when it finishes its charging process. 

Fast Charge: It’s possible to charge the battery with a current higher than the one above calculated, on 

the other hand, this process may cause the battery to warm up and will decrease its lifetime. 

Charging Cycles: You should avoid charging the battery for a few minutes or even a couple of hours, this 

way you are shortening its capacity and its lifetime. Respecting the charging and discharging cycles extends 

its longevity. 

Polarity: Verify if you connect the charger with the correct polarity (“+” “-“)! 

 

3.2. HANDLING THE BATTERY  

Make sure the battery cable is properly attached to the robot before you plug the battery connector! This 

prevents short circuits in your battery. 

Never short circuit the battery terminals! This will destroy the battery and may even start a fire. 
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4. BOT’N ROLL ONE A+ ASSEMBLY  

The Bot'n Roll ONE A+ assembly is carried out in three steps: 

1 – Mechanical Assembly 
2 – Electronic Assembly 
3 – Electrical Wiring 

 

TIP: Put the battery to charge when you start building your robot, so that after assembling it is ready to 

use. It takes about 8 hours for a battery to fully charge. Do not leave the battery charging for longer than 

8 hours otherwise you may damage it. Since these are Ni-MH batteries you must perform complete 

charges and discharges, rather than charging just a few minutes or even one or two hours. Short charges 

reduce the battery capacity and its lifetime. 

 

4.1. TECHANICAL ASSEMBLY  

For the mechanical assembly, you will need the 

motors, the wheels, the motor supports, hubs, 

screws and the acrylic base. 

 

Before you start assembling the robot, remove the 

two protective plastic layers form the acrylic base! 

 

  

IMPORTANT NOTE: Some tools not included on this kit might be necessary, namely multimeter, PH1 
and PH2 Phillips screwdriver, flat nose pliers, soldering iron, soldering wire, de-soldering pump, 
cutting pliers. 

Fig. 6: Preparing the acrylic base 
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4.1.1. MOTORS  

 

The setting of each motor is performed using a motor 

support with two M3 embedded nuts, two M3x6mm PH1 

screws and two M3x12m PH1 screws. 

 

You need a Phillips PH1 screwdriver and a 1.5mm hex 

wrench included in the mechanical components bag. 

 

 

Fix the motor to the support using the two smaller 

M3x6mm PH1 screws. 

Use the Phillips PH1 screwdriver to tighten the screws 

conveniently. 

 

 

Attention !! To work correctly the motors have mirrored 

positions. 

 

 

 

Fix the support with the motor to the acrylic base using 

the two longer M3x12mm PH1 screws and M3 nuts 

embedded in the support.  

 

 

 

The acrylic base has a hole to pass the motors wires to 

connect later on to the printed circuit board. Pass the 

wires through the hole according to the image. 

 

 

  

Fig. 7: Required equipment to set the motors 

Fig. 8: Fixing the L shape motor support to 

 the motor itself 

Fig. 10: Fixing the motors to the acrylic base 

Fig. 9: Correct positioning of motors (mirrored) 

Fig. 11: Passing the motors wires through the 

acrylic base 
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4.1.2. DRIVING WHEELS  

The Bot'n roll ONE A+ moves around using two drive 

wheels that are connected to the motors. They are made 

of plastic with a rubber coating.  

In order to attach each wheel, it is necessary to use an 

engagement “hub”, a hexagon M3x3mm bolt and a 

M4x6mm PH2 screw. 

 

 

 

The motor shaft has a surface that is not round! Use this 

flat area to mechanically lock the bolt hub and prevent it 

from rotating on the shaft. This way you assure that all 

energy from the motor is transmitted to the wheels! 

 

 

Fit the hub on the motor shaft and the hex bolt screws 

against the flat area of the shaft using a 1.5mm hex 

wrench. 

 

 

 

Insert the wheel on the hub, pushing it against the 

hexagonal tip of the hub. 

 

 

 

Lock the wheel to the hub using the M4x6mm PH2 screw 

and tighten it conveniently! 

 

 

  

Fig. 13: Assembling the driving wheels 

IMPORTANT NOTE: Check that there are no gaps 
between the wheel and the motor as this will 
influence the robot movement! 

Fig. 12: Components to fix the driving wheels 
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4.1.3. CASTER WHEEL  

 

The caster wheel is necessary to support the robot, and it is 

used to adjust the inclination according to your needs. 

Therefore, you have to adjust the robot height in its rear. 

To place the caster wheel, two M5x20mm PH2 screws and six 

M5 nuts are used. 

 

 

 

 

Insert the screws into the acrylic base and attach two M5 

nuts on each screw.  

 

 

 

 

Place the caster wheel inserting the screws into the 

corresponding holes and tighten the last M5 nut on each 

screw.  

 

 

 

 

Use the M5 nuts on each side of the caster wheel to adjust 

the robot’s inclination. 

Check that there are no loose nuts, and that the caster 

wheel aligns properly with the drive wheels as it influences 

the movement of the robot. 

 

 

 

Congratulations!  You finished assembling the mechanics of your Bot’n Roll ONE A+! 

You can move on to the electronic assembling.  

Fig. 14: Caster wheel, bolts and nuts 

Fig. 15: Assembling the caster wheel and 

adjusting of the robot inclination 
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4.2. ELECTRONICS ASSEMBLY  

For the electronics assembly you require the following tools 

(not supplied with the robot): 

• Soldering iron 

• Soldering wire 

• De-soldering pump 

• Cutting pliers 

 

 

 

 

4.2.1. PRINTED CIRCUIT BOARD (PCB)  

 

 

You must insert the components respecting the serigraphy (white letters) but solder them on the opposite 

side. It is not necessary to solder the components on the serigraphy side because the holes are plated and 

therefore, they allow the passage of electric current.  

The Printed Circuit Board (PCB) contains small 

holes to insert the electronic components. 

The silk screen printing (description of components 

in white) identifies the position and orientation of 

each electronic component on the Printed Circuit 

Board. 

The Printed Circuit Board acts as a base for the 

electronic components and contains all the 

connections between them, according to the 

wiring diagram of the robot. 

 

Fig. 16: Required material for electronics assembly 

IMPORTANT NOTE: In this stage, all electronic components are soldered to the Printed Circuit 
Board. For a correct soldering process, we strongly recommend all components to be soldered 
sequentially as presented in this manual. Bad soldering can cause destruction of components and 
the printed circuit board, therefore, before you start soldering you must read the “Crash course on 
Soldering” available on Bot’n Roll ONE A+ supplied manuals. 

Fig. 17: Printed Circuit Board (PCB) 
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4.2.2. RESISTORS  

 

 

Electrical resistance is the name given to an element 

that opposes the passage of electric current (direct 

or alternating).  

Usually a resistance is represented by the letter R and 

its unit of measurement by the Ohm (Ω). 

 

The nominal value is represented by coloured bands (colour code), which satisfies the following 

criteria: left to right the first two coloured bands form a 2 digit number, the third colour is the 

multiplier, which corresponds to the exponent of the power of 10 that multiplies the original number, 

and finally the fourth colour (slightly shifted to the right) corresponds to the tolerance in percentage. 

 

Colour 1st Band 2nd Band 3rd Band 4th Band 

 1st Figure 2nd Figure Multiplier Tolerance % 

Silver   0.01  +/- 10 
Gold   0.1  +/- 5 
Black 0 0 X 1 No colour +/- 20 
Brown 1 1 X 10 Silver +/- 1 
Red 2 2 X 100 Gold +/- 2 
Orange 3 3 X 1,000  +/- 3 
Yellow 4 4 X 10,000  +/- 4 
Green 5 5 X 100,000   
Blue 6 6 X 1,000,000   
Violet 7 7    
Gray 8 8 X 0.1   
White 9 9 X 0.01   

Table 1: Resistance colour codes 

 

Example: What is the value of the resistor on the picture? 

The first two colours: yellow (4) and violet (7) form the 

number 47. The third colour, orange (3), corresponds to the 

exponent of the power of ten: 103, or multiply by 1000, the 

fourth colour, silver (10%), indicates the tolerance. Thus, the 

electrical resistance is: 

R = 47000Ω with 10% tolerance or R = (47 000 Ω ± 4700Ω) 

 

Fig. 19: Resistance – lines with colour codes 

Fig. 18: Resistor example 
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Taking as reference the following table, solder the resistors in the 

corresponding locations on the printed circuit board: 

Solder the resistors value 1KΩ ±5% 

(Colours: Brown, Black, Red and Gold) on R1, R10, R11, R12, R16, R17 ,R19, 

R20, R21, R22, R24 ,R26 and R27; 

 

Solder the resistors value 10KΩ ±5% 

(Colours: Brown, Black, Orange and Gold) on R3, R4, R5, R8, R9, R13, R14, 

and R25; 

 

Solder the resistors value 120Ω ±5% 

(Colours: Brown, Red, Brown e Gold) on R18, R28 and R29; 

 

Solder the resistor value 1MΩ ±5% 

(Colours: Brown, Black, Green and Gold) on R23; 

 

Solder the resistors value 3,3KΩ ±5% 

(Colours: Orange, Orange, Red e Gold) on R2, R6 and R7. 

 

Tip: First, place all the resistances in the 

proper places slightly bending the terminals 

of each resistance.  

Press the resistance against the desk before 

applying the solder process.  

After soldering cut the terminals as short as 

possible to avoid short-circuits. 

 

 

  

Description Component 

R1 1 KΩ 

R2 3,3 KΩ 

R3 10 KΩ 

R4 10 KΩ 

R5 10 KΩ 

R6 3,3 KΩ 

R7 3,3 KΩ 

R8 10 KΩ 

R9 10 KΩ 

R10 1 KΩ 

R11 1 KΩ 

R12 1 KΩ 

R13 10 KΩ 

R14 10 KΩ 

R15 10 KΩ 

R16 1 KΩ 

R17 1 KΩ 

R18 120 Ω 

R19 1 KΩ 

R20 1 KΩ 

R21 1 KΩ 

R22 1 KΩ 

R23 1 MΩ 

R24 1 KΩ 

R25 10 KΩ 
R26 1 KΩ 

R27 1 KΩ 
R28 120 Ω 
R29 120 Ω 

Fig. 21: Resistors on the Printed Circuit Board 

Fig. 20: Bot'n Roll ONE A+ resistors 
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4.2.3. DIODES  

The board uses two different diodes with references:  

1N4934, used to drive the motors and to protect the power circuit 

of the robot. 

Zener 5v1, used as a protection element in the battery 

measurement circuit. 

 

The diodes have polarity, and therefore, must be placed with 

the correct orientation! Each diode has a mark that must match 

with the mark represented on the serigraphy of the printed circuit 

board (Error! Reference source not found.).  

The diode reference is printed on the component itself. 

 

Place the Zener 5V1 diode on Z1. 

Place the 1N4934 diode on positions: D1, D2, D3, D4, D5, D6, D7, D8, 

D9, D10, D11 and D12. 

 

  

Description Component 

D1 1N4934 

D2 1N4934 

D3 1N4934 

D4 1N4934 

D5 1N4934 

D6 1N4934 

D7 1N4934 

D8 1N4934 

D9 1N4934 

D10 1N4934 

D11 1N4934 

D12 1N4934 

Z1 Zener 5v1 

The conventional diode consists of two blocks of semiconductor 

material, a N-type doped with negative ions (-), and a P-type doped 

with positive ions (+). 

As main characteristic, the diode allows the electric current to flow 

only in one direction (left to right as shown in the picture). 

To indicate the polarity, the diode has a mark that points to the 

corresponding edge of the cathode. The electric current flows from 

the anode (+) to the cathode (-) and not in reverse. 

The Zener diode differs from the conventional diodes in being able 

to drive in both directions (direct and reverse), in controlled 

situations, without damaging itself. The Zener diode has an 

associated reverse voltage that remains constant in a situation 

where the current flows in the opposite direction. This allows it to 

be used in Bot'n Roll ONE A+ as a protection element in the battery 

measurement circuit. It works as a voltage limiter. To its terminals, 

voltage never rises above 5.1 V and thus the PIC18F45K22 will never 

be damaged in case the battery accidentally has excessively high 

voltages. 

Fig. 22: Diode 

Fig. 23: Zener Diode 

Fig. 24: Robot Diodes 

Fig. 25: Diodes location 



Bot’n Roll ONE A+ User Assembling Manual   

©Copyright 2025, SAR - Soluções de Automação e Robótica, Lda. 21 

4.2.4. CRYSTAL OSCILLATOR  

On the printed circuit board serigraphy, the crystal oscillator is 

represented by “XTAL”. 

 

 

 

 

4.2.5. INTEGRATED CIRCUIT SOCKETS  

There are 4 sockets to insert the ATmega328, PIC18F45K20 and two 

LS7184 integrated circuits. These sockets have 28, 40 and 8 pins 

respectively.  

Each socket has a slot at one end that should match the serigraphy 

on the board. The placement of the sockets must respect these 

slots because they are very important in inserting the integrated 

circuits. The integrated circuits also have that slot. If you insert an 

integrated circuit in the wrong orientation, you will damage it 

permanently! 

The sockets must be soldered on U1, U2, U4 and U5 respectively.  

  

Description Component 

XTAL Crystal 16MHz 

Description Component 

U1 28 pins socket 

U2 40 pins socket 

U4 8 pins socket 

U5 8 pins socket 

A crystal oscillator is an electronic component that uses the 
resonant properties of a piezoelectric crystal, to create an 
electrical signal with a very precise frequency. Bot'n Roll ONE A+ 
uses a 16MHz quartz oscillator crystal which makes the IC 
ATmega328 to operate at a 16MHz clock frequency.  
Like traditional watches, which also use a crystal, the usage of a 
crystal makes the Bot'n Roll ONE A+ a very accurate machine to 
measure time.  

Fig. 26: Crystal Oscillator 

Fig. 27: Crystal Oscillator on the board 

The sockets for integrated circuits allow easy replacement of the integrated circuits in case they 

are damaged. Never solder integrated circuits directly on the PCB! 

IMPORTANT NOTE: The ATmega328, PIC18F45K20 and LS7184 
integrated circuits will be inserted later in the sockets. Should 
only be inserted in step 0 after wiring the board. 

Fig. 28: Integrated circuits sockets 



Bot’n Roll ONE A+ User Assembling Manual   

©Copyright 2025, SAR - Soluções de Automação e Robótica, Lda. 22 

4.2.6. POTENTIOMETERS  

The printed circuit board has four 10KΩ potentiometers. 

Its value is written on the side, as explained on Fig. 30. 

 

The inscription P 103 corresponds to 10 000Ω, i.e., 10 KΩ. 

 

The BR potentiometer regulates the LCD display brightness. 

The CT potentiometer regulates the LCD display contrast. 

The IRD1 potentiometer regulates the left obstacle sensor 

detection distance. 

The IRD2 potentiometer regulates the right obstacle sensor 

detection distance. 

 

 

4.2.7. PUSH BUTTONS  

Four push buttons allow you to interact with the robot. You can, for 

instance, navigate on menus and change settings on your program 

quickly and without connecting your robot to the computer. 

Use the push buttons PB1, PB2 and PB3 to interact with your robot 

and to navigate on menus displayed on the LCD. 

The Reset push button resets the Arduino. 

  

Description Component 

BR Potentiometer 10KΩ 

CT Potentiometer 10KΩ 

IDR1 Potentiometer 10KΩ 

IDR2 Potentiometer 10KΩ 

Description Component 

PB1 Push button 

PB2 Push button 

PB3 Push button 

Reset Push button 

A potentiometer is a variable resistor, i.e., its value can be adjusted, 
and this way, one can control the intensity of the current flowing in 
a given circuit. In Bot'n Roll ONE A+, potentiometers allow 
adjustment of the obstacle sensor detection distance, the contrast 
and brightness of the LCD display. 

Fig. 29: Potentiometers 

Fig. 30: Potentiometers location 

A push button places an electrical signal on the circuit while being 
pressed. 

Fig. 31: Push buttons 
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4.2.8. COLOURED LEDS  

The Light Emitting diodes (LED’s) indicate the status of your 

Bot’n Roll ONE A+. 

The green LED ON indicates that the robot is powered.  

The yellow LED’s are for “debugging” and are controlled by 

your program. 

The red LED’s are associated to the obstacles detection circuit. 

Place the green LED where ON is indicated in the PCB. 

Place the yellow LED’s on L and LED. 

Place the red LED’s on IRS1 and IRS2. 

 

4.2.9. INFRARED EMITTERS  

The infrared emitters are used in the obstacle detection circuit. They 

emit light that is reflected by the obstacles. 

Place the infrared emitters on positions IRE1 and IRE2 

facing outwards.  

Description Component 

ON LED green 

L LED yellow 

LED LED yellow 

IRS1 LED red 

IRS2 LED red 

Description Component 

IRE1 Infrared emitter 

IRE2 Infrared emitter 

An LED – Light Emitting Diode, consists of a PN junction of a 

semiconductor material and two terminals, the anode (A, 

positive terminal) and cathode (K, negative terminal).  

The colour of the light emitted by the LED depends on the 

semiconductor material. 

Like the diode, the LED has polarity. The flat spot identifies the 

cathode (-) and is associated with the shorter leg. 

Warning: Never look directly to the light emitted by an LED. At 

a short distance, the light is strong enough to injure the retina 

and the damage is permanent! 
Fig. 32: LED 

IMPORTANT NOTE: Do not forget that the LED’s have 
polarity! You must insert the longest leg of each LED 
on the “+” indication on the board. 

Fig. 33: Bot’n roll ONE A+ LED’s 

Infrared emitters are LED’s that emit infrared light. This light is 

not visible to the human eyes, but it causes damage to the 

retina as in a conventional LED! 

Using a video camera, like a web cam for example, one can check 

whether the LED’s are working or not. 

Fig. 34: Infrared emitters LED's 
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4.2.10. BUZZER  

 

The buzzer can be used to create melodies or warning sounds, 

for example, to indicate that the battery voltage is too low. 

 

 

 

 

 

 

 

 

 

4.2.11. MAIN SWITCH  

 

 

 

The main switch allows you to power the robot ON and OFF. 

It must be soldered on SW "Switch". 

Bot'n Roll ONE A+ will be powered ON when you slide the 

switch to the front side of the robot. It will be OFF if you slide 

the switch back! 

 

 

 

  

Description Component 

Buzzer Buzzer 

Description Component 

SW Main switch 

The buzzer is a transducer that converts electrical pulses into sound. 

Fig. 35: Buzzer 

A switch is a device that interrupts the power supply 

(electric current) to the circuit 

Fig. 36: Main switch 
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4.2.12. CERAMIC CAPACITORS  

 

Bot'n Roll ONE A+ uses ceramic capacitors with two 

distinct values: 22pF and 100nF. 

The 22pF capacitor has the legend 22 and the 100nF 

capacitor has 104K written on it. 

Place the 100nF capacitors on C1, C2, C3, C4, C6, C7, C10, 

C11, C14 and C15. 

Place the 22pF capacitors on C12 and C13. Note that 

33pF capacitors can also be used as an alternative! 

 

  

Description Component Inscription 

C1 100nF 104K 

C2 100nF 104K 

C3 100nF 104K 

C4 100nF 104K 

C6 100nF 104K 

C7 100nF 104K 

C10 100nF 104K 

C11 100nF 104K 

C12 22pF 22 

C13 22pF 22 

C14 100nF 104K 

C15 100nF 104K 

The capacitor is a component that stores energy between two 

conducting plates (𝐸 = 1
2ൗ 𝐶𝑉2). It is used to stabilize the energy 

on the robot circuits. 

The capacitance (C) relates the stored charge with the voltage at its 

terminals (𝐶 =
𝑄
𝑉ൗ ). The capacitor is made up of two conductive 

plates that are separated by an insulator or dielectric. 

There are monolithic capacitors, with no polarity (a) and 

electrolytic, with polarity (b). 

(a) (b) 

Fig. 37: Capacitor: (a) monolithic, 

(b) electrolytic 

Fig. 38: Capacitors location 
Fig. 39: Ceramic capacitors 
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4.2.13. MOTORS AND ENCODERS CONNECTORS  

The motors come with embedded encoders that work using A and 

B quadrature encoder interface  

For each motor a 6-pin connector is needed. Establishing 

connection for the positive and negative of the motor, the encoders 

power (VCC and GND) and the encoders two channels (A and B)  

Place the connector respecting the delimiting serigraphy (with the 

open side of the connector facing the wire passage) and solder all 

terminals on the PCB. 

 

4.2.14. BIPOLAR TRANSISTORS  

The two PNP BC557 transistors are placed on Q1 and Q2. 

 

 

These components are present in the infrared emitter circuit, 

working as switches, allowing the PIC18F45K22 to turn OFF and 

ON the infrared LED's with high power. Thus, the obstacles can 

be detected at great distances!  

  

Description Component 

Motor + Enc R 1x6 male connector 

Motor + Enc L 1x6 male connector 

Description Component 

Q1 BC557 Transistor 

Q2 BC557 Transistor 

A transistor is a semiconductor device used to amplify or switch electrical signals. On Bot'n Roll ONE 
A+ it is used in the obstacles detection circuit to increase the power of the light emitted by the infrared 
LED's. 

It consists of three layers of semiconductor material of P and N types and has three terminals: Emitter, 
Base and Collector. The provision of the three layers P and N set to PNP or NPN transistor.  

When used as an amplifier, the current is flowing between the 
collector and emitter (output). When the transistor acts as 
switch, the base input signal toggles the output signal. 
Depending on the transistor connection configuration, the 
amplified or toggled signal in the output can be inverted or 
not, regarding the input signal. 

Fig. 42: NPN bipolar transistor 

Transistors have polarity! Only work properly if placed 
correctly in the circuit. You must match the flat surface of the 
transistor with the flat line on the board´s serigraphy. 

The connectors allow you to connect the motors and 

encoders to the PCB.  

Fig. 40 - Motor connectors 

Fig. 43: BC557B PNP Transistor 

Fig. 41 - Connectors location 

http://en.wikipedia.org/wiki/File:NPN_BJT_(Planar)_Cross-section.svg
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4.2.15. ARDUINO CONNECTORS  

 

 

Solder each of the five connectors on the rows with the same number of pins as the connector. 

Check that they are properly aligned and touching the printed circuit board!  

Each of the five Arduino connectors has its specific function: 

The POWER connector is the Arduino Power connector. All 

robot circuit voltages are available here: 

 5V, 3.3V, VIN (battery voltage) and GND (0V). 

The RESET pin is connected to the Arduino Reset button and 

the IOREF is reserved for future shields. 

The AD connector is located at the analog inputs of the 

Arduino Analog to Digital Converter (ADC). Here you can 

connect analog sensors whose signal vary between 0V and 5V. 

With just some lines of code, you can get the corresponding 

digital value. Should you use I2C communication you cannot 

use the A4 and A5 pins as inputs for the ADC, since they are 

reserved for the I2C communication.  

Next to the AD connector, you will find a group of triple 

connections that have the same A0-A5 identification. Here 

you can connect analog sensors that also require voltages 

between 0V and 5V. On this group of connectors, the "s" pins 

correspond to the analog inputs, "-" corresponds to the 0V 

and "+" corresponds to 5V.  

On the IOL and IOH connectors, you have the Arduino digital inputs and outputs (I/O) and each of these 

pins can be configured by software as a digital input or output. On each of the 0 to 13 outputs, you can 

place a 0V or 5V signal that correspond to the Low and High states respectively. On the pins with the 

symbol “~”, for example “~3” you can have a PWM output and here you can control servomotors, like the 

ones used on the gripper. When configured as digital inputs, to connect digital sensors for example, on 

each of these pins you can check whether you have 5V or 0V. The SCL and SDA pins are used for I2C 

communication and correspond to A4 and A5 pins of the AD connector. The AREF pin should only be used 

in case you require an external reference voltage for the ADC conversions, but this voltage can only vary 

between 0V and 5V! 

Next to the IOL and IOH connectors, you will find a group of triple connections that have the same 

identification. Here you can connect digital sensors and actuators that require voltage between 0V and 5V. 

On this group of connectors, the “s” pins correspond to the digital pins, the “-” corresponds to the 0V and 

the “+” corresponds to 5V. 

The ICSP connector allows SPI communication with shields and the ICSP (In Circuit Serial Programming) 

programming of the Arduino bootloader.  

Description Component 

ICSP Header, 3-Pin, Dual row male 

AD Header, 6-Pin female 

IOL Header, 8-Pin female 

IOH Header, 10-Pin female 

POWER Header, 10-Pin female 

The set of five connectors allows the 

connection of Arduino Compatible “shields”, 

like the wireless XBee communication shield. 

Fig. 44: Arduino connectors 
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4.2.16. JUMPERS  

Bot'n Roll ONE A+ has one 2-positions jumper.  

 

The 2-positions jumper PSEL "Power Selection" allows you to select 

whether the servos are powered by the 7805 voltage regulator or the 

PWR voltage regulator dedicated to the servos. 

Place the male connector in PSEL. 

 

4.2.17. LINE SENSOR CONNECTOR  

 

To electrically connect the Line Follower to the Printed 

Circuit Board a 5-Pin, Dual row connector is supplied. 

Place the connector on the Line Sensor and solder all 

terminals on the PCB. 

 

 

 

4.2.18.  I2C CONNECTORS  

Place the connectors on I2C1 and I2C2. Note that the small 

rectangular mark in the serigraphy represents the plastic casing 

brake of the connector. The connectors should be placed 

respecting the correct positioning. 

 

  

Description Component 

PSEL 2-positions jumper Header, 3-Pin, male  

Description Component 

I2C1 NCDW 2.54 mm 4-pins 

I2C2 NCDW 2.54 mm 4-pins 

A jumper is a connector that allows you to electrically 

configure the robot, directing the electric current to 

certain areas of the circuit 

ATENTION: Respect the orientation indicated on the 
serigraphy, otherwise, you won’t be able to connect 
the Line Sensor!  

Fig. 46: Line follower connectors 

These connectors allow you to plug devices that use I2C 

communication protocol like compasses, accelerometers, sonar, 

temperature and humidity sensors, etc. 

Fig. 47: I2C connectors 

Fig. 45: Jumper 
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4.2.19. ELECTROLYTIC CAPACITORS  

 

They should be placed on C8 and C9 with the longest terminal 

inserted into the location identified by the symbol "+" on the 

serigraphy. 

 

 

 

The capacitors value is 100μF. 

 

4.2.20. POWER CONNECTORS  

 

Following the sizing markings of the serigraphy the connector is 

placed on the “Bat” mark with the connection holes facing the 

wire passage. 

 

 

 

4.2.21. USB - SERIAL CONVERTER  

This device is placed on the “USB” mark of the serigraphy. 

 

  

Description Component 

C8 100µF 

C9 100µF 

Description Component 

USB USB converter 

Electrolytic capacitors have polarized terminals! As such, 

when placed on the printed circuit board, you have to 

respect their polarity. 

Fig. 48: Electrolytic capacitors 

The power connector allows you to connect the battery to the 

PCB. The wires are secured by pressure  

Fig. 49: Power connectors location 

The USB – Serial (RS232) converter is the device which allows 

programming the robot through a computer USB port. 

Fig. 50: USB converter 
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4.2.22. HEAT SINK  

 

 

 

Attach the LM7805 to the heatsink using the bolt and nut 

provided. Put together the smooth inner surface of the 

heatsink, and the metallic surface of the LM7805! 

 

4.2.23. VOLTAGE REGULATORS  

 

 

According to the serigraphy, place the LM2940T-3.3 where 

indicated “2940 3.3V” and the LM7805 where indicated “7805 

VCC”. 

 

You must solder the LM7805 with the heat sink already placed! 

 

 

Components orientation must be respected. Note that the 

double line on the serigraphy corresponds to the metallic surface 

of the component. 

  

Description Component 

7805 LM7805 

Description Component 

7805 LM7805 

2940 LM2940T-3.3 

A heat sink is a metallic object that reduces the working 

temperature of a component. It avoids the component to 

be damaged due to excessive temperature and increases its 

lifetime. 

Fig. 51: Heat sink 

The LM7805 and LM2940T components are linear voltage 

regulators to supply specific voltages for powering the circuit. 

The 7805 serves as a power source for devices that work at 5 

volts while the LM2940T power devices that work at 3.3 Volts. 

Fig. 52: 2940 and 7805 Voltage regulators 
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4.2.24. FUSE AND FUSE HOLDER  

 

To protect against short circuits a 4A fuse with a fuse-holder is 

used. If the electric current supplied by the battery exceeds 4A, 

the fuse will burn. 

 

Description Component 

F1 Fuse support 

 

The fuse holder must be inserted in the printed circuit 

board on “F1”. 

Place the 4A slow blow fuse on the fuse support. 

 

Close the cover with the fuse inside.  

 

 

4.2.25. L298 H BRIDGE0 

 

Description Component 

U3 L298N 

 

Place the L298N on “U3”.  

  

The L298N component corresponds to a double H bridge to 

drive, independently, each motor of the robot, allowing control 

of speed and direction. 

This component allows a maximum current of 2A on each 

motor for continuous operation. For short moments (up to 100 

us), it enables a 3A debit for each motor. 

A fuse is a protective device comprising of a metallic 

conductor that melts as soon as the electric current flowing 

through it exceeds the specified value 

Fig. 53: Placing the fuse in the circuit 

Fig. 54: L298N integrated circuit 
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4.2.26. INFRARED RECEIVERS  

 

Two infrared receivers are placed at the bottom of the 

printed circuit board, unlike all the components already 

soldered. 

 

Insert the VISHAY TSSP4056 receivers under the PCB on 

IRR1 "Infra-Red Receiver 1" and IRR2, with the sensors 

facing outwards as illustrated on Fig. 55.  

 

These receivers must be soldered on the top side of the 

PCB, opposite to what you have done so far.  

 

  

Description Component 

IRR1 VISHAY TSSP4056 

IRR2 VISHAY TSSP4056 

The infrared receivers are sensors that detect infrared light 

reflected by obstacles. This light is emitted by the infrared 

LEDs as a 56 KHz modulated signal, i.e. each LED turns on 

and off 56,000 times per second! If the LEDs do not emit at 

this frequency the infrared receiver sensors will not detect 

obstacles. 

Fig. 55: Infrared receivers 
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4.2.27. LCD  

 

To hold the LCD a 16 pins header connector, two M3x10 

PH1 screws, two nylon spacers and two M3 nuts are 

provided. 

To attach the LCD, you have to remove the piece of plate 

that fills the output hopper. Use a file/sandpaper to 

smooth the output hopper, if necessary, so that the LCD 

enters effortlessly. 

The LCD enters from the bottom of Bot'n Roll ONE A+ PCB. 

Before inserting it, place the 16-pin header connector 

between the LCD and the board with the longer pins facing 

down. 

Insert the LCD on the board and place the two screw 

assemblies, nylon spacer and nut, as indicated in the 

figure and attaching the LCD to the printed circuit board 

by tightening the screws. 

Check that the 16-pin header connector has been 

"sandwiched" between the LCD and the Bot'n Roll ONE A+ 

PCB, with the pins inside the holes of the LCD link on the 

robot board. 

Confirm that the LCD is horizontally aligned and solder the 

16-pin header connector to Bot'n Roll ONE A+ PCB. 

Afterwards solder the 16 pins underneath on the LCD. 

 

 

The removed piece of PCB board is designed to be used as 

a unique and distinctive keyring! 

 

  

Description Component 

LCD 1x16 connector 

The LCD is a device that enables the robot to interact with the 

user through written messages, for example, states of the 

program or the value of variables. 

The Bot'n Roll ONE A+LCD is alphanumeric, has 2 lines with 16 

characters each. It has adjustable contrast and brightness. 

Fig. 56: Placing the LCD 
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4.2.28. USB-SERIAL CONVERTER PROTECTION CASING  

 

The USB-Serial converter is a component that is subject to 

constant physical stress resulting from the introduction and 

removal of the USB cable. A 3D printed PLA plastic casing was 

developed to “embrace” and protect the USB-Serial converter 

maintaining the integrity of its structure. 

 

 

Place the plastic protection on the USB-Serial converter so the 

USB connection for the cable is visible. Verify that the two holes 

on the bottom of the protection casing are aligned with the 

holes on the PCB. 

 

 

Insert the two M3x6mm screws into the holes and tighten them 

using a PH1 screwdriver, threading them into the plastic 

protection. Thread the screws until the bottom of the plastic 

casing touches the PCB but not tighten too much that you grind 

the plastic material! 

 

Verify that the screws are not in contact with the welds, it may 

cause short-circuits! 

 

 

The USB-Serial converter is now physically protected and a lot 

more robust for everyday use! 

 

 

 

 

  
Fig. 57: Placing the USB-Serial protection 

plastic casing 



Bot’n Roll ONE A+ User Assembling Manual   

©Copyright 2025, SAR - Soluções de Automação e Robótica, Lda. 35 

4.3. WIRING AND TESTING  

4.3.1. CONNECTING THE BATTERY  

 

The battery connector is plugged in “Bat”. The red wire must 

be connected to the “+” mark on the serigraphy and the black 

wire to the “-”.  

In this case, the Polarity is EXTREMELY important! 

To secure the wire gently pull back the orange lever place the 

wire in the correct location and then release the lever. Make 

sure the wire is firmly fixed. 

The wires passage from the lower part of the robot to the 

printed circuit board is through the central hole on the acrylic 

base.  

 

 

 

 

4.3.2. ASSEMBLY ELECTRICAL CHECK  

Now, connect the charged battery to the robot and verify that the ON 

LED turns on and off when you use the main switch.  

Check with a voltmeter that the 5V, 3.3V and VIN (battery voltage) 

voltages are present in the Arduino Power Connector (VIN-IOREF). You 

should always measure with respect to GND that corresponds to 0V. 

If any of the above does not happen, it means that there were 

problems during the assembling. You should fix it before going to the 

next step. In the table below we present some tips to help you solving 

the problem:  

 

 

VERY IMPORTANT NOTE:  
Short-Circuiting the battery might initiate a fire! 
Never connect the battery to the robot before finishing 
all connections!  
 
Before removing the battery cable from the "Bat" 
connector, ensure that the battery is NOT connected to 
the cable!  

Fig. 58: Plugging the battery wires 

Fig.59: LED ON 
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Possible cause / Inspection Solution 

The battery is not properly inserted on 
the connector. 

Insert the battery correctly and check that the connector 
tab is latched. 

The battery wires are not properly 
connected to the Bot’n Roll ONE A+ 
printed circuit board. 

Check whether the wires are securely fastened to the 
"Bat" connector and perform a continuity test with a 
multimeter. 

The fuse is not inserted in the circuit. 
Insert the fuse as indicated on section 3.2.17 of this 
manual. 

The fuse blew. 
Most likely, there is a short circuit on the board. Check 
solders, identify and remove the short circuit before 
inserting a new fuse. 

The fuse is not blown but the green LED 
ON does not light up or the voltages are 
not all present on the Arduino connector. 

In this case, there might still be a short circuit but the 
electric current is not enough to blow the fuse. Check the 
temperature of the voltage regulators 7805 and 2940. 

One or both voltage regulators are too 
hot. 

There is great probability of a short circuit. Check solders, 
identify and remove the short circuit. There is still a small 
chance of a component being damaged. 

The voltage regulators do not warm up, 
the ON LED does not light up or the 
power connector voltages of the Arduino 
are not present. 

It is likely that there are bad solders and contact between 
the components and the board is faulty. Identify cold 
solders, in which the solder wire does not shine and apply 
the soldering iron again until you see the solder melt 
completely. Add more solder wire if necessary. 

The voltage regulators did not warm up, 
the Power connector voltages are 
present but the Power ON LED does not 
light.  

The Arduino connector’s voltage are 
present but the ON LED does not light up. 

You should confirm that the LED ON is soldered according 
to the polarity, where the + corresponds to the longest leg. 
Check the polarity of the ON LED with a multimeter. 

After checking all the above possibilities, 
the problem still exists. 

Contact the help service on botnroll.com. 

  

IMPORTANTE NOTE: To proceed to the next step and continue the robot assembly you must 
disconnect the battery  

http://www.botnroll.com/
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4.3.3. INTEGRATED CIRCUITS PLACEMENT  

On the robot, two DIP format integrated circuits and are used: 

PIC18F45K22: 40-pins processing unit (PIC). 

ATmega328: 28-pins processing unit (Arduino). 

LS7184: 8-pins integrated circuit. 

 

It may be necessary to align the pins of 

integrated circuits before inserting them 

on the sockets. Do this carefully because 

the pins are fragile and can break if not 

done properly or bended several times, 

becoming irreparably damaged. 

 

 

  

Description Component 

U1 ATmega328 

U2 PIC18F45K22 

U4 LS7184 

U5 LS7184 

An integrated circuit is a miniaturized electronic circuit consisting 

mainly of semiconductor devices such as transistors. The number 

of transistors on integrated circuits can vary from a couple of 

transistors to tens of millions of transistors. 

NOTE: Before inserting the integrated 
circuits ensure that the Bot'n Roll ONE 
A+ is powered OFF. 

IMPORTANT NOTE: The integrated circuits have a unique inserting position. In one of the edges, a cavity 
corresponds to the printed mark on the PCB serigraphy. 
Insert the ATmega328 on U1, the PIC18F45K22 on U2 and the two LS7184 on U4 and U5. 

Fig. 60 Integrated circuits insertion 
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4.3.4. LINE SENSOR  

The Line Follower (Pololu© QTR-8A) has 8 analog infrared 

sensors which Bot’n Roll ONE A+ can use to follow a line. 

Cables previously prepared and a 5-pin, dual row connector 

establish the link between the Line Follower and Bot’n Roll 

ONE A+.  

Together with the Line follower, the following parts are 

supplied: 

• 2 x 35mm PLA stands 

• 2 x M2x4mm screws 

• 2 x M2x10mm screws 

Remove the battery before proceeding with the Line sensor placement. 

The acrylic base has three sets of 2mm holes that allow you 

to place the line follower in three different configurations: 

forward, central and backward.  

The forward position of the line follower is far away from 

the wheels and this allows a better control of the robot 

movement when following the line, however, it may limit 

the robot mobility on steep ramps. 

The backward configuration allows Bot'n Roll ONE A to easily overcome steep ramps because the line 

follower is placed beside the wheels. However, it is more difficult to control the robot, in terms of software, 

to follow the line.  

In the central position, you have a balance between the 

two extreme configurations, i.e., better movement control 

than the backward configuration and better mobility than 

the forward configuration. 

Fix the Line Sensor supports to the acrylic base using the 

longer screws. Notice that the supports are not circular 

shaped, for greater support position them with the pointed 

tip turned inwards, as shown in Fig. 63. 

Fix the Line Sensor to the supports using the shorter 

screws. Respect the sensor’s direction 

Use the central hole of the acrylic base to guide the Line 

Sensor cables from bottom to top.   

IMPORTANT NOTE: The PLA is a plastic material, 
therefore do not tighten too much the screw, 
because you might grind the screw thread! 

Fig. 61: Line Follower 

Fig. 62: Three different configuration options 

Fig. 63 Supports positioning on the acrylic base 

Fig. 64 Line Sensor assembled on Bot’n Roll ONE A+ 
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4.3.5. FIXING THE PCB ON THE ACRYLIC BASE  

Fixing the robot board to the acrylic base is carried out 

by using 6 sets of: 

• 1x 12mm PLA spacer; 

• 1x M3x8 PH1 screw 

• 1x M3x4 PH1 screw. 

 

Insert each M3x8 PH1 screw on the acrylic base from 

bottom to top and screw a spacer until it is tightened. 

Repeat for each of the six spacers. 

 

 

 

Place the electronic board passing the motors wires by 

the centre hole and attach it using the M3x4 PH1 screws 

through the spacers. 

 

 

 

Tighten the screws with a Phillips screwdriver so that 

there are no gaps between the PCB, the nylon spacers 

and the acrylic base. 

 

 

 

 

 

 

4.3.6. CONNECTING THE MOTORS  

The connection of the motors is carried out on the Motor + 

Enc L and Motor+Enc R connectors. The left motor connects 

to Motor + Enc L and the right one to Motor + Enc R. 

The connectors should be placed with the correct 

orientation, check that the black wire is connected to the 

GND pin.  

Fig. 65: Required parts to hold the PCB 

on the acrylic base 

Fig. 66: Assembling the PCB on the 

acrylic base 

Fig. 67: Motors connection 
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4.3.7. BATTERY PLACEMENT  

The battery is placed on the bottom part of the acrylic base 

using three Velcro strips. 

Before attaching the Velcro strips check that the area is not 

sticking dirty, or greasy!  

If necessary, use a glass-cleaning product to clean the 

surfaces and let them dry properly! 

Glue the two velcro strips to the battery pressing hard for 

proper attachment. Afterwards, remove the stickers 

protection to place the battery on the robot. 

 

Put the battery on the Bot'n Roll ONE A+ pressing again for 

a good grip. Attention not to damage the components on 

the robot board! 

 

After the battery is secured with Velcro and fully charged, 

attach the connector and Bot'n Roll ONE A+ is ready to be 

programmed! 

 

TIP: when attaching the connector pass the battery wires between the caster wheel screws, this way the 

wires won’t get in the way or influence the robot’s movement. 

 

 

Well done! 

Fig. 68: Battery placement 
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5. INSTALLING THE USB-SERIAL (RS232) CONVERTER VCP DRIVER  

The driver allows your computer's operating system to communicate with the Bot'n Roll ONE A+.   

To install the driver, visit the Bot’n Roll ONE A+ support page (http://botnroll.com/one-a-plus/) and 

download it by clicking on “VCP Driver - Windows” or “VCP Driver - Mac OS X”, according to your operating 

system. Once the download is complete, extract the file with the “.zip” extension and run the application.   

Whenever you connect the robot to the computer using the USB cable, a virtual COM port (VCP) is created, 

through which communication between the Bot'n Roll ONE A+ and the PC takes place. The application for 

programming the robot uses this port to communicate with the Bot'n Roll ONE A+ and transfer programs 

to the robot.   

The USB-Serial converter used in the Bot'n Roll ONE A+ is a PoUSB12 from PoLabs, which uses the CP2102 

Bridge device from Silicon Labs. 

For more information check our Arduino Software user manual at our website. 
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6. ARDUINO PROGRAMMING ENVIRONMENT  

The software used for programming the robot is Arduino IDE 2.0. This application is necessary for editing 

programs in C++ language. It is also used to transfer your programs to the Bot’n Roll ONE A+. 

6.1. ARDUINO IDE INSTALATION  

To install the Arduino IDE, visit the Bot’n Roll ONE A+ support page at (http://botnroll.com/one-a-plus/). 

In the "Software | Drivers" section, click on "Arduino IDE" to install it according to your operating system.   

Once the download is complete, extract the ".zip" file and place the extracted folder in a directory of your 

choice on your computer.   

This folder contains several subfolders and files, including the "arduino.exe" application, the executable 

that launches the Arduino IDE. 

6.2. BNRONEAPLUS LIBRARY INSTALLATION ON ARDUINO IDE 2  

Libraries are your working tools in programming. The "BnrOneAPlus” library, developed by botnroll.com 

for the Arduino IDE, contains all the necessary commands for controlling the robot. This library must be 

installed in the Arduino IDE.   

To install the library in Arduino™ IDE 2, click on the "Sketch" tab → "Include Library" → "Manage 

Libraries...", search for "BnrOneAPlus" and install the library by clicking the "Install" button.   

To install the library in Arduino™ IDE 1, click on the "Sketch" tab → "Include Library" → "Add .ZIP 

Library...", select the BnrOneAPlus.zip file, and the library will be installed automatically. Close and reopen 

the Arduino™ IDE to ensure the library is functional!   

The procedures for installing the VCP driver and the “BnrOneAPlus” library are also described in the 

Assembly Manual. 
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6.3. CONFIGURING COMMUNICATION WITH THE ROBOT  

Before performing this step, make sure you have installed the VCP driver correctly. Connect the Bot’n Roll 
ONE A+ to the computer using the supplied USB cable. At this point, a COM port will be automatically 
assigned for communication with the robot. 

Open the Arduino IDE, and in the top bar of the 
window, find a menu where you can choose the 
Board and the Port. Select the board “Arduino 
Uno”. The Bot’n Roll ONE A+ will be pro-
grammed as if it were an Arduino Uno. 

 

 

 

If it does not appear instantly, you can click on 

“Select other board and port...” and the following 

menu will appear. Choose the board “Arduino 

Uno” and the corresponding COM port to program 

the Bot'n Roll ONE A+. 

 

 

 

If no COM port is available, it is most likely that you have not correctly installed the VCP driver for the 
USB-to-Serial converter. 

Open the Windows Device Manager and look for the item 
labelled “Ports (COM & LPT)”. Expanding this item, you will 
see all the assigned COM ports. 

 

“Silicon Labs CP210x USB to UART Bridge” is the designa-
tion that identifies the connection port to the Bot’n Roll 
ONE A+. (In the example from the figure, COM21 was as-
signed.) 

 

If the item “Silicon Labs CP210x USB to UART Bridge” does 
not appear, you will need to correctly install the VCP driver. 

 

  

Fig. 69: Selecting the board to program 

Fig. 70: Selecting the Serial port 

Fig. 71: COM ports on the device manager 
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6.4. LOADING A PROGRAM TO BOT'N ROLL ONE A+  

In the Arduino programming environment, 

you will find several example programs that 

you can load onto the robot. 

Click on “File -> Examples -> 01.Basics -> 

Blink” and a new window will appear with 

the code for this example. 

 

Click on “File -> Upload” or press the arrow 

symbol pointing to the right to upload the 

program to the robot. Once the upload is 

complete, you should see the yellow L LED 

blinking every second!  

 

Clicking on “File -> Examples -> BnrOneAPlus -

> …” you will find all the example programs 

provided by botnroll.com specifically for the 

Bot'n Roll ONE A+. 

In “File -> Examples -> BnrOneAPlus -> Basic -

>...”, you will find the basic programs designed 

to test all the robot's hardware. You should 

study and understand these small programs 

well! 

In “File -> Examples -> BnrOneAPlus -> 

Advanced -> ...”, you will find more advanced 

programs that you should only study after 

understanding the simpler ones. 

 

In “File -> Examples -> BnrOneAPlus -> Extra -> 

...”, you will find programs related to the extra 

components that expand your Bot'n Roll ONE 

A+. 

In “File -> Examples -> BnrOneAPlus -> Fun 

Challenge -> ...”, you will find programs related 

to the Fun Challenge. 

In “File -> Examples -> BnrOneAPlus -> Calibrate 

-> ...”, you will find programs related to 

calibrating your Bot'n Roll ONE A+. 

In “File -> Examples -> BnrOneAPlus -> 

CrazyRace -> ...”, you will find programs related 

to the CrazyRace challenge. 

In “File -> Examples -> BnrOneAPlus -> Obstacle 

Sensors -> ...”, you will find programs related to 

obstacle sensors. 

In “File -> Examples -> BnrOneAPlus -> Line 

Sensor -> ...”, you will find programs related to 

line sensor. 

 

Fig. 72: Loading an example program 

Fig. 73: Sending a program to the robot 

Fig. 74: Programs from the BnrOneAPlus library 
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7. BOT'N ROLL ONE A+ HARDWARE TEST  

After your robot have successfully passed the electrical test (section 4.3.2 of this manual), it is necessary 

to test all Bot'n Roll ONE A+ devices individually and verify they are operating correctly. You will have to 

program the robot with the corresponding sample codes and perform the test described on each of the 

following points listed, in the presented order! 

 

7.1. “L” LED  

Using the Arduino IDE open the example program “Blink” located on “File -> Examples -> 01.Basics -> 

Blink” and program the robot clicking on “Upload”. When the upload ends, you must see the L LED 

blinking every second. 

 

If the L LED does not light up check if there is any short-circuit or bad solders on:  

• L LED; 

• R19 resistor; 

• Pin 13 of the Arduino 8-SCL connector; 

• ATmega328 integrated circuit socket. 

Assure that you have soldered the L LED respecting its polarity. You can verify that using a multimeter or 

comparing the internal connections of the LED with an identical one. 

7.2. BUZZER  

Load the “Buzzer” program located on “File -> Examples -> BnrOneAPlus -> Basic -> Buzzer” to the robot. 

When the upload ends, you should listen a melody emitted by the buzzer. This indicates that the buzzer is 

working properly. 

Should the buzzer not play the melody, check if the BUZZ jumper is placed correctly and if there is any 

short-circuit or bad solders on: 

• Buzzer; 

• R18 resistor; 

• ATmega328 integrated circuit socket. 

 

7.3. DEBUG "LED" 

Load the program “LED” located on “File -> Examples -> BnrOneAPlus -> Basic -> LED” to the robot. When 

the upload ends, you should see the LED blinking each second. 

Should the LED not emit any light you must check for short-circuits or bad solders on: 

• LED LED; 

• R18 resistor; 

• Pin 13 of the Arduino 8-SCL connector; 

• PIC18F45K22 integrated circuit socket. 

• ATmega328 integrated circuit socket. 
 

Assure that you have soldered the LED LED respecting its polarity. You can check that using a multimeter 

or comparing the LED internal connections with an identical one.  



Bot’n Roll ONE A+ User Assembling Manual   

©Copyright 2025, SAR - Soluções de Automação e Robótica, Lda. 3 

7.4. LCD  

Load the “LCD” program located on “File -> Examples -> BnrOneAPlus -> Basic -> LCD” to the robot. When 

the upload ends, you should see the "LCD Test OK !!" message on the LCD. 

Should you not see the message, check that: 

• The robot main switch is ON; 

• You correctly adjusted the LCD brightness using the BR potentiometer; 

• You correctly adjusted the LCD contrast using the CT potentiometer; 

If you still cannot see the message on the LCD verify that there are no short-circuits or bad solders on: 

• LCD 16 pins connector; 

• BR potentiometer; 

• CT potentiometer; 

• PIC18F45K22 integrated circuit socket. 

• ATmega328 integrated circuit socket. 
 

7.5. PUSH-BUTTONS  

Load the “Push-buttons” program located on “File -> Examples -> BnrOneAPlus-> Basic -> PushButtons” 

to the robot. When the upload ends, you can see on the LCD the button number you are pressing: 

• 0 if no button is being pressed 

• 1 if PB1 button is pressed 

• 2 if PB2 button is pressed 

• 3 if PB3 button is pressed 
 

If any button does not work properly check that there are no short-circuits or bad solders on: 

• PB1 switch; 

• PB2 switch; 

• PB3 switch; 

• R6 resistor; 

• R7 resistor; 

• R8 resistor; 

• PIC18F45K22 integrated circuit socket. 

• ATmega328 integrated circuit socket. 
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7.6. BATTERY  

Load the "Battery" program located on "File -> Examples -> BnrOneAPlus -> Basic -> Battery" to the robot. 

When the upload ends, you should see the battery voltage value on the LCD. 

If the voltage value is not between 9.0V and 14.0V, check that: 

• The robot main switch is ON; 

• The battery is charged; 

• The resistor on R2 is 3.3kΩ; 

• The resistor on R3 is 10kΩ; 

• Placed the Zener diode Z1 with the correct orientation. 
 

If the problem continues verify that there are no short-circuits or bad solders on: 

• C1 capacitor; 

• R2 resistor; 

• R3 resistor; 

• Z1 diode; 

• SSP jumper; 

• PIC18F45K22 integrated circuit socket. 

• ATmega328 integrated circuit socket. 

 

7.7. MOTORS  

Load the "Motors" program located on "File -> Examples -> BnrOneAPlus -> Basic -> Motors" to the robot. 

When the upload ends, the motors might start moving and a message is shown on the LCD describing the 

movement being carried out. 

Should some motor not move check: 

• The robot main switch is ON; 

• The battery is charged; 

• The Motor+Enc L connector is tightened; 

• The Motor+Enc R connector is tightened; 

• The hubs are properly placed on the motors; 

• The robot wheels are properly tightened to the hubs. 

 

If the problem continues verify that there are no short-circuits or bad solders on: 

• C3 capacitor 

• D1, D2, D3, D4, D5, D6, D7 and D8 diodes; 

• Motor+Enc L connector; 

• Motor+Enc R connector; 

• U3 (L298N) integrated circuit; 

• PIC18F45K22 integrated circuit socket; 

• ATmega328 integrated circuit socket. 
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7.8. INFRARED LED'S  

Load the “_01_EmittersOnOff” program located on “File -> Examples -> BnrOneAPlus-> ObstaclesSensor 

-> _01_EmittersOnOff” to the robot. When the upload ends, the infrared LED’s will commute each second 

with its respective status information shown on the LCD. 

Use a mobile phone camera (without infrared filters) to check that LEDs are blinking, since human eyes 

cannot see this type of light. 

If some of the infrared LEDs do not emit any light, adjust the corresponding potentiometer (IRD1 for IRE1 

and IRD2 for IRE2) until you see light being emitted by the LED. 

If the problem continues verify that there are no short-circuits or bad solders on: 

• IRE1 LED; 

• Q1 transistor; 

• IRD1 potentiometer; 

• R16 and R28 resistors; 

• IRE2 LED; 

• Q2 transistor; 

• IRD2 potentiometer; 

• R21 and R29 resistors; 

• PIC18F45K22 integrated circuit socket. 

• ATmega328 integrated circuit socket. 
 

7.9. OBSTACLE SENSORS  

Load the “_02_ObstaclesRead” program located on “File -> Examples -> BnrOneAPlus-> ObstaclesSensor 

-> _02_ObstaclesRead” to the robot. When the upload ends, the infrared LED’s will emit infrared light 

which when reflected by an obstacle will make the IRS1 and IRS2 LED's blink. 

On the LCD, a message with the obstacle proximity indication is written and the values vary from 0 to 25: 

• 0 the sensors do not detect any obstacle; 

• 25 the obstacle is very close to the robot. 

Put your hand in front of the infrared LED´s to simulate an obstacle and check that the IRS1 and IRS2 LED's 

blink and at the same time the respective message is presented on the LCD. 

If some of the IRS1 or IRS2 LED's do not flash, verify there are no short-circuits or bad solders on: 

• IRS1 LED; 

• IRR1 sensor; 

• R17 resistor; 

• IRS2 LED; 

• IRR2 sensor; 

• R22 resistor; 

• PIC18F45K22 integrated circuit socket. 

• ATmega328 integrated circuit socket. 
 

Assure that you soldered the IRS1 or IRS2 LED's respecting its polarity. You can check this using a 

multimeter or comparing the LED's internal connections with identical ones. 

Place the robot against an obstacle, like wall or a white paper sheet, and adjust the desired distance using 

the IRD1 and IRD2 potentiometers and a screwdriver. 
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7.10. MOTORS CALIBRATION  

Load the “MotorsCalibrate” program located on “File -> Examples -> BnrOneAPlus-> Advanced -> 

MotorsCalibrate” to the robot. When the upload ends you are going to configure the necessary power to 

move the motors. 

The goal of this process is to register the necessary power for the robot to initiate movement and the 

battery voltage in that precise moment. The robot will use these calibrating values to improve motion with 

very low speeds and to maintain a constant velocity as battery voltage drops while discharging. 

The LCD presents the power (PWM from 0 to 100) applied to the motors. Using the push-button PB1 you 

will increase the power until the robot starts moving forward. In that precise moment you lift the robot 

and press the PB3 push-button to save the values in the robot´s memory. The LCD will present a message 

stating the data was saved. 

This calibrating process must be done whenever you switch the battery for another with a different 

nominal voltage or the motors for others with different nominal rotation or gear ratio. 

 

Your Bot'n Roll ONE A+ is now complete and functional! Use your imagination and explore the fantastic 

world of Robotics… Congratulations! 

IMPORTANTE NOTE: Calibrating the motors must be done using a fully charged battery and with the 
robot placed on a flat surface! 
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8. EXTRAS 

A wide range of components can be integrated in your Bot'n Roll ONE A+ and thus increasing its 

functionalities. Arduino compatible shields as wireless XBee, Bluetooth, RF, GPS, GPRS and sensors like 

line follower, sonar, compass, encoders and any I2C device can be added to your Bot'n Roll ONE A+ and 

imagination is the limit! 

Also a Raspberry pi add-on bringing even more possibilities to take your robot to the next level! 

On the extras user manual you will find a detailed description of some of these components. Visit the 

Bot’n Roll ONE A+ support web page http://botnroll.com/onea/ to get the respective user manual. 

You can also visit the www.botnroll.com website for more information.  

 

 

 

Fig.75 Extras on Bot'n Roll ONE A+ 

http://botnroll.com/onea/
http://www.botnroll.com/


Bot’n Roll ONE A+ User Assembling Manual   

©Copyright 2025, SAR - Soluções de Automação e Robótica, Lda. 8 

9. ANNEX 

9.1. BOT'N ROLL ONE A+ ELECTRONIC BOARD COMPONENTS LIST  

 

Qt Description Qt Description 

1 1M Ohm Resistor 1 Header 3X2 

3 120 Ohm Resistor 1 Header 3 

3 3k3 Ohm Resistor 1 Header 6 

5 10K Ohm Resistor 1 Header 8 

17 1K Ohm Resistor 2 Header 10 

1 Zener diode 1 Jumper 

12 FR203 diode 1 Line Sensor connector 

1 16MHz Crystal 2 I2C_BUS 

1 IC 28 Pin IC Sockect 3 100uF capacitor 

1 40 Pin IC Sockect 1 Battery connector 

2 8 Pin IC Sockect 1 USB-Serial Connector 

4 10K Ohms Potentiometer 1 LM2940T-3.3-TT Voltage Regulator 

4 Pressure buttons 1 LM7805 Voltage Regulator 

1 Green LED  1 Thermal dissipator 

2 Red LED  1 Fuse Support 

2 Yellow LED 1 2A Fuse 

2 22pF capacitor 1 H bridge L298N 

2 Infrared LED  2 TSSP4056 

1 Buzzer 1 LCD 

1 Switch Power 1 Header 16 

10 100nF capacitors 1 ATmega328-PU 

2 Motor Connector 1 PIC18F45K20-E/P 

2 BC557 transistor 2 LS7184 
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9.2. ELECTRIC SCHEMATICS  

 


